tora with oracle on debian/ubuntu — prebuilt package

I’ve received much more requests for the prebuilt package than I originally thought — apparently this problem affects many people. As such, I’ve put the .deb package online: you can get it here.

This does raise the question however whether a tora-oracle package shouldn’t be available in Debian’s non-free section, like seems to have been done with RPMs. I would think it doesn’t pose any licensing issues. Unless of course such a package includes some of Oracle’s library files, but doesn’t it only link against them? I could be way off here though.
Should the package give you any troubles, I’d be interested to know (see my ‘about‘ page for my e-mail address, or leave a comment). If it works, I’m also interested. Especially whether it works on Ubuntu as well would be interesting to know — although I don’t see a reason why not.

(For those who haven’t read my previous entry: it contains instructions to build the package yourself, if that’s more your thing.)



  1. […] Update: I’ve posted a new article which contains the prebuilt package I mentioned. […]

  2. Nerijus said

    Ubuntu 6.10 – the Edgy Eft

    sudo dpkg -i tora-with-oracle_1.3.21-3_i386.deb
    Selecting previously deselected package tora.
    (Reading database … 129163 files and directories currently installed.)
    Unpacking tora (from tora-with-oracle_1.3.21-3_i386.deb) …
    dpkg: dependency problems prevent configuration of tora:
    tora depends on libqt3-mt (>= 3:3.3.7); however:
    Version of libqt3-mt on system is 3:3.3.6-3ubuntu3.
    dpkg: error processing tora (–install):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:

  3. ludoa said

    Hi Nerijus,
    Thanks for letting me know. Your version of libqt3-mt is too low. Is it possible for you to upgrade it, or isn’t this in Ubuntu yet?
    I’d try to rebuild it with libqt3-mt 3.3.6 installed, but I don’t have it anymore in my cache, and can’t seem to find it on the ‘net. seems to only index stable’s repository, not unstable.
    I could be mistaken, but I think it should work anyway. You could try forcing it:
    dpkg -i --force-depends-version tora-with-oracle...deb
    Also, Ivo List pointed out that –with-kde does work, and that –without-kde doesn’t enable copy-pasting results. I’ve verified this, and built a new package – see as I really recommend the tora-with-oracle-and-kde package.
    Good luck! If it doesn’t work, please tell me what error message you get – if it does work, please also tell 🙂

  4. Nerijus said

    Hi, Ludoa,

    with -force-depends-version flag it is installed successfully but with broken dependencies under ubuntu Edgy…
    Anyway thanks for help 😉

  5. ludoa said

    Hi Nerijus,

    Looks like you’ll have to wait for libqt3-mt 3.3.7 to come in Ubuntu then…

    One other thing you could try (depending on how badly you want TOra with Oracle) is to install libqt3-mt 3.3.7 from Debian Sid. You will probably need these as well, though: libqt3-compat-headers libqt3-headers
    If those are the only packages you need to upgrade, this can be a very quick fix.

    You could also just try to build it yourself, as I described in the previous blog post.

  6. Martin McWhorter said

    I am having the same problem.

    I gave up trying to build the package under Ubuntu-6.10 after struggling to get debian/rules to configure the OCI app.

    If anyone has Tora with Oracle built for Edgy, please let me know.


  7. ludoa said

    What about –force-depends-version? Re-reading Nerijus’ post, I’m not sure how to interpret it… i.e. does it work fine, and is the only problem that apt is complaining about it? If so, I suppose there’s a way around this, so you can make apt keep quiet about it.
    Also, as I previously mentioned, getting Debian’s libqt3 packages might work. If it doesn’t work, you could just revert to Ubuntu’s packages.
    Doesn’t Ubuntu have a repository with more up-to-date/experimental packages where you could find a more recent version of libqt3?


  8. Martin McWhorter said


    I interpreted Nerijus’ post as saying that that it would install, but not work. I will try it. Unfortunately, seems to be down right now. If you can email me the deb packages (with and w/out KDE) that would be great. My browser put them in /tmp, so I don’t have them this morning 😦


  9. Stephen Crowley said

    Argh, the site is down!

  10. ludoa said

    I’m sure it’s only temporary. Either way, I mailed you the file. If anyone else needs it, e-mail me (see my about page for my address).

  11. Piyush Jain said

    I got this when tried to run with –force-depends-version flag

    dpkg: error processing tora-with-oracle_1.3.21-3_i386.deb (–install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:

  12. david said

    Any luck with this? If anyone has installed on edgy by building from source or by installing libqt3-mt 3.3.7 please post.

  13. Martin McWhorter said

    dpkg –force-depends-version -i tora-with-oracle_1.3.21-3_i386.deb

    This command works for me. Unfortunately it leaves the deb/apt in an inconsistent state.

  14. serpini said

    please, the site is down!

  15. ludoa said

    Martin: great, thanks for posting that. It does make apt annoying, yep.
    I’m surprised Ubuntu doesn’t update its packages more often, I thought it was relatively bleeding edge?
    Anyway, that’s another reason to move to the real thing – Debian GNU/Linux 😉

    Serpini: yes, the site seems to be having a lot of problems. Could somebody please mirror them? I’ll gladly e-mail the packages to anyone who wants to mirror them.

    Oh, and if someone knows a decent free shell account, I’m always interested.

  16. ludoa said

    Martin McWorther found a fix for those having problems with Ubuntu:
    More on tora-with-oracle on Edgy.

    Ok, so after I installed and got Tora with Oracle working using the –force-depends-version, I notices that some of the auto update, apt-get and aptitude would fail because of the depend version inconsistancy.

    So I figured this easy fix,

    Install the newer 3:3.3.7 libqt3-mt from the feisty development tree

    1. Add this line to /etc/apt/source.list
    deb feisty main restricted

    2. run
    apt-get install -f
    This will solve the dependancy by installing the feisty libqt3-mt and its dependencies from feisty.

    3. Comment the line out of source.list so you don’t accidentally upgrade your distribution version.

    There may be an easier way to get the deb database to live with the version inconsistency. I am very new to the debian world, being a Redhat guy for eight years.


    Thanks a lot Martin!

  17. ludoa said

    I uploaded the package to divShare. The URL is . I don’t know for how long it’ll be available there, however, so mirrors are still more than welcome.

    Edit: some more mirrors, as I have no idea how long these will all last:

    (BTW is a great site for this kind of stuff – not as nice as , but very cool none the less.)

  18. Martin McWhorter said


    I can’t recommend using the feisty dependencies in edgy anymore. It seemed to cause even more inconsistencies unless I wanted to completely upgrade to the development branch.

    Now I just keep the tora-with-oracle package and re install dpkg after installing any new pacages or updates with apt/aptitude as it will replace the tora with the Ubuntu package.

  19. ludoa said

    Sorry to hear that Martin. Maybe someone else who manages to install it using the longer explanation on my blog post can build Ubuntu packages of it. Other than that, I could try running an Ubuntu live cd, and compiling new TOra packages against Ubuntu’s libqt, etc.

    Edit: just thought of this, AFAIK it should be possible to build static packages. Those will be bigger (maybe slower too?) but since they don’t link against outside libraries, it should work I think. Anyone an idea of how I can build such static binaries?


  20. Martin McWhorter said

    *Fix for apt wanting to replace tora with the Ubuntu tora package*

    I don’t know if this works with Edgy or Dapper as I just upgraded to Feisty beta today (update-manager -d). Good news is that with Feisty you do not need the –force-depends-version to install.

    Try this on Edgy or Dapper as well, it should work:
    vim /etc/apt/preferences

    (new file) and create these three lines:
    Package: tora
    Pin: version 1.3.21-3
    Pin-Priority: 1001

    Now do a:
    aptitude update && aptitude upgrade

    See! It does not tell you that it wants to upgrade tora to the Ubuntu repository version. The orange icon in the corner telling you to upgrade tora should go away too.

  21. ludoa said

    Glad to hear that, Martin — especially as Ubuntu is set to be released in seven days, if I’m not mistaken. Looking at Feisty’s specs, it seems like it’ll be a great release, too. Hope some of it will find its way into Debian… (like the OOo spellcheck/thesauri work)

  22. I have the Tora with Oracle (with and w/out KDE) up at:

  23. sandrar said

    Hi! I was surfing and found your blog post… nice! I love your blog. 🙂 Cheers! Sandra. R.

  24. […] I’ve posted a new blog entry which contains the prebuilt package I […]

RSS feed for comments on this post · TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )


Connecting to %s

%d bloggers like this: